Pete´s Messageboard... No ISO/BIOS requests!

Homepage Members Register Login Search Old board


Neuer Thread ...


AuthorTopics » Book an abo for this threadClose Thread Move Thread Fix the thread Print view Delete this thread

rocklikeafool 



...

Status:Offline
Date registered: 28.10.2013
Post:1
Send Message
...   Created on 28.10.2013 - 01:40Jump to top Quote this post Report this post Edit Delete


Hey, I had some issues with sound when I selected the Linux SPU plugin in ePSXe.

In order to log things in the Ubuntu terminal, I set up a shell script and ran it in the terminal. Then, I started up an ISO and the log showed the following:

Code:
1:
2:
3:
4:
 
 * SPUplayCDDAchannel disabled 
 * Init spu[0][libspuPeopsOSS.so.1.0.9] 
Sound device not available!
 * Open spu[0]


Note that I'm using ePSXe v1.9.0 Linux. How would I resolve the issue? Any ideas?




The_Source ...
Real addict
.........

...

Status:Offline
Date registered: 14.07.2004
Post:527
Send Message
...   Created on 17.12.2013 - 14:21Jump to top Quote this post Report this post Edit Delete


You need an OSS installed and configured in your system, but most distros now prefer ALSA+PulseAudio.
You can try:
1. Enable oss emulation in ALSA (haven't tried myself). Read this for instructions http://alsa.opensrc.org/OSS_emulation

2. Compile P.E.Op.S. SPU with ALSA support. Get sources: http://sourceforge.net/projects/peops/f … z/download
Edit Makefile to enable ALSA support instead of OSS, also you will probably need to modify some compiler flags for compatibility with modern gcc. You'll need 32bit alsa-devel package.
I tried this myself and the sound was lossy. For example many sounds are corrupted in Castlevania: SotN.

3. You can use Eternal SPU 1.41 for linux. http://www.zophar.net/download_file/3261
Uses SDL, works best for me, some background sounds may vanish on load state until reloaded by game though.

Note, methods 1 and 2 will probably require that no other processes lock the card, so if you are running pulseaudio, temporarily stop it.





Signature
He wants to cure the minds,
The minds of entire humankind



Similarly threads:
Topics Created by Replies Boardname
Running Man lilly65 1 rumpelstar
Running Away Jenny 0 fridayhill
running away MaNu 0 bs4ever
Just Running Away Luzie4Lee 8 fridayhillfanforum
Running Order Tim_Lehmann 20 havgan
Neuer Thread ...





Masthead

This forum is a free service of razyboard.com
Do you want a free forum in less than two minutes? Then click here!



Verwandte Suchbegriffe:
sound device not available ep
blank